weblogic报错unsupported classversion 51.0 _Tomcat, WebLogic及J2EE讨论区_Weblogic技术|Tuxedo技术|中间件技术|Oracle论坛|JAVA论坛|Linux/Unix技术|hadoop论坛_联动北方技术论坛  
网站首页 | 关于我们 | 服务中心 | 经验交流 | 公司荣誉 | 成功案例 | 合作伙伴 | 联系我们 |
联动北方-国内领先的云技术服务提供商
»  游客             当前位置:  论坛首页 »  自由讨论区 »  Tomcat, WebLogic及J2EE讨论区 »
总帖数
1
每页帖数
101/1页1
返回列表
0
发起投票  发起投票 发新帖子
查看: 2069 | 回复: 0   主题: weblogic报错unsupported classversion 51.0         上一篇   下一篇 
landy
注册用户
等级:新兵
经验:61
发帖:72
精华:0
注册:2011-12-31
状态:离线
发送短消息息给landy 加好友    发送短消息息给landy 发消息
发表于: IP:您无权察看 2015-6-8 18:05:17 | [全部帖] [楼主帖] 楼主

weblogic11g 部署应用,激活更改时,报错:

激活更改期间出错, 有关详细信息, 请查看日志。


[HTTP:101371]There was a failure when processing annotations for application D:\software\hedu.war. Ensure that the annotations are valid. The error is Class bytes found but defineClass()failed for: 'com.reremouse.servlet.DownloadFileQuestionAttach'
com/reremouse/servlet/DownloadFileQuestionAttach : unsupported classversion 51.0


原因是生成war包是jdk1.7环境,weblogic自建域是jdk1.6

解决办法,使用jdk1.6生成war包。

--转自 北京联动北方科技有限公司




赞(0)    操作        顶端 
总帖数
1
每页帖数
101/1页1
返回列表
发新帖子
请输入验证码: 点击刷新验证码
您需要登录后才可以回帖 登录 | 注册
技术讨论